执行insert报错Expected state to be Connected but was ClearingPendingCancellation.

【TiDB 使用环境】生产环境
【TiDB 版本】8.5.1
【操作系统】
【部署方式】云上部署(什么云)/机器部署(什么机器配置、什么硬盘)
【集群数据量】
【集群节点数】
【问题复现路径】
【遇到的问题:问题现象及影响】麻烦问下大家,有人遇到过这个问题么?程序在执行insert的时候,报错Expected state to be Connected but was ClearingPendingCancellation.查看当时的日志,有下面截图中报错,看了主要原因是tidb终止了数据库连接。但是不知道原因是啥。
【资源配置】进入到 TiDB Dashboard -集群信息 (Cluster Info) -主机(Hosts) 截图此页面
【复制黏贴 ERROR 报错的日志】
【其他附件:截图/日志/监控】

日志里面不是写了么?sql killer , 是被人手工删掉的,还是超时的哪种,你可以自己查下了

执行耗时多长,有设置过max_execution_time之类的参数么

这个报错,是指数据库主动kill的,不是人手工删掉的。而且这个是通过定时任务调度的,不会手工去kill掉的

这个sql执行不到3秒,也查了这个参数,没有做限制的

用那个用户执行的呢,查下那个用户有没有配置一些runaway,资源管控的那些配置,正常也不会配置到3s啊感觉

有做RU限制,但是没有配置runway,RU应该是充足的

那使用下非限制RU的用户跑一下这个任务,看会不会有问题,也有可能是RU这块的问题,如果是的话再找找是否有对应的bug

谢谢您的建议,但是这个是偶现的 :joy:

偶现还可以狠稳定么… 我好奇~~

偶现就太奇怪了,没有规律么,没有其他人有操作权限么

sql没执行完好像